Uploaded image for project: 'Terrier Core'
  1. Terrier Core
  2. TR-334

Terrier can not parse topic file when it contains only IDs (not English words)

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 4.0
    • Fix Version/s: 4.1
    • Component/s: .querying
    • Labels:
      None

      Description

      I am doing indexing for medical documents, and instead of indexing the English terms I am annotating the terms in both of the documents and query.
      So I have something like a sequence if "C092736" .

      Terrier can not index those terms, can I override that?

        Attachments

          Activity

          shadisaleh shadi saleh created issue -
          craigm Craig Macdonald added a comment -

          Tagging for 4.1.

          craigm Craig Macdonald made changes -
          Field Original Value New Value
          Fix Version/s 4.1 [ 10070 ]
          craigm Craig Macdonald added a comment -

          Hi. This isn't a bug per-se, but by design. You need to override EnglishTokeniser such that the check() method isn't called.

          craigm Craig Macdonald made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Won't Fix [ 2 ]

            People

            • Assignee:
              craigm Craig Macdonald
              Reporter:
              shadisaleh shadi saleh
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: