Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 3.5
    • Fix Version/s: 4.0
    • Component/s: .querying
    • Labels:
      None

      Description

      When i am trying to query the terrier collection for doc with a 5 digit number in the num tag an exception is being thrown .

      The error is as follows:
      Setting TERRIER_HOME to /home/akanchha/Desktop/terrier-3.5
      INFO - Loading document lengths for document structure into memory
      INFO - Structure meta reading lookup file into memory
      INFO - Structure meta reading reverse map for key docno directly from disk
      INFO - Structure meta loading data file into memory
      INFO - time to intialise index : 4.028
      ERROR - Error instantiating topic file QuerySource called TRECQuery
      java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
      at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
      at org.terrier.applications.TRECQuerying.getQueryParser(TRECQuerying.java:797)
      at org.terrier.applications.TRECQuerying.<init>(TRECQuerying.java:344)
      at org.terrier.applications.TrecTerrier.run(TrecTerrier.java:393)
      at org.terrier.applications.TrecTerrier.applyOptions(TrecTerrier.java:564)
      at org.terrier.applications.TrecTerrier.main(TrecTerrier.java:235)
      Caused by: java.lang.NullPointerException
      at org.terrier.structures.TRECQuery.extractQuery(TRECQuery.java:163)
      at org.terrier.structures.TRECQuery.extractQuery(TRECQuery.java:87)
      at org.terrier.structures.TRECQuery.<init>(TRECQuery.java:272)
      ... 9 more
      A problem occurred: java.lang.NullPointerException
      java.lang.NullPointerException
      at org.terrier.applications.TRECQuerying.processQueries(TRECQuerying.java:829)
      at org.terrier.applications.TrecTerrier.run(TrecTerrier.java:394)
      at org.terrier.applications.TrecTerrier.applyOptions(TrecTerrier.java:564)
      at org.terrier.applications.TrecTerrier.main(TrecTerrier.java:235)

      The file is as attached.

      A full description of the command and error is as attached.

        Attachments

          Activity

          craigm Craig Macdonald added a comment -

          Your topic file has a topic number with more than 4 digits. This is known bug in 3.5, fixed in Terrier version 4.


            People

            • Assignee:
              craigm Craig Macdonald
              Reporter:
              akanchha Akanchha Choubey
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: