Uploaded image for project: 'Terrier Core'
  1. Terrier Core
  2. TR-26

SingleLineTRECQuery doesnt parse Million Query track topics files

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.2.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      ERROR - Error instantiating topic file tokeniser called SingleLineTRECQuery
      java.lang.reflect.InvocationTargetException
              at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
              at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39)
              at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27)
              at java.lang.reflect.Constructor.newInstance(Constructor.java:513)
              at uk.ac.gla.terrier.applications.TRECQuerying.getQueryParser(TRECQuerying.java:469)
              at uk.ac.gla.terrier.applications.TRECQuerying.<init>(TRECQuerying.java:155)
              at TrecTerrier.run(TrecTerrier.java:416)
              at TrecTerrier.applyOptions(TrecTerrier.java:565)
              at TrecTerrier.main(TrecTerrier.java:244)
      Caused by: java.lang.StringIndexOutOfBoundsException: String index out of range: -1
              at java.lang.String.substring(String.java:1938)
              at uk.ac.gla.terrier.structures.SingleLineTRECQuery.extractQuery(SingleLineTRECQuery.java:103)
              at uk.ac.gla.terrier.structures.TRECQuery.<init>(TRECQuery.java:197)
              at uk.ac.gla.terrier.structures.SingleLineTRECQuery.<init>(SingleLineTRECQuery.java:66)
              ... 9 more

        Attachments

          Activity

          craigm Craig Macdonald added a comment -

          Cause is that TREC single line topic files may not have a space, but just a colon. Simple patch attached.

          craigm Craig Macdonald added a comment -

          Committed to trunk.


            People

            • Assignee:
              craigm Craig Macdonald
              Reporter:
              craigm Craig Macdonald
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: