Uploaded image for project: 'Terrier Core'
  1. Terrier Core
  2. TR-239

Clarify when Terrier Query language can be used viz TREC

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.5
    • Fix Version/s: 3.6
    • Component/s: .querying
    • Labels:
      None

      Description

      Hi

      i have indexed 2 documents that contain 4 words, used blok indexing

      fist doc: english football player dance
      second doc: football player dance english

      i have a query phrase "english football", but the result for the tow document is tha same as english football, there is a thing that i missing to use phrase?

      also i tested english football^2.3 the reult is the same

      what is the problem?

      Thanks

        Attachments

          Activity

          thespirit chedi bechikh added a comment -

          i fix it, the problem is that documentation is incomplete, please note in the documentation that to use query language we must use single line query
          Best regards

          craigm Craig Macdonald added a comment -

          Documentation fix is required

          richardm Richard McCreadie added a comment -

          I this is a legacy of the Tokenisation change in 3.5.

          SingleLineTRECQuery uses the new Tokeniser.getTokeniser() method, which defaults to EnglishTokenizer (that does not keep query language characters).
          TRECQuery uses TRECFullTokenizer that keeps all characters

          tokeniser should be set to a tokeniser that supports the query language.

          richardm Richard McCreadie added a comment -

          Tagging for addition in configure_retrieval.html

          Possible additions

          • Difference between TRECQuerying, TRECQuery and SingleLineQuery
          • Effect of Tokenisation
          • Query language
          richardm Richard McCreadie added a comment -

          Updated query language documentation. Resolving issue.


            People

            • Assignee:
              craigm Craig Macdonald
              Reporter:
              thespirit chedi bechikh
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: