Uploaded image for project: 'Terrier Core'
  1. Terrier Core
  2. TR-13

Allow fields to contain count information

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 3.0
    • Labels:
      None

      Description

      The fields support introduced for Terrier 1.0 centre around the concept of 'does the term occur in field f in this document?'

      However, these fields pre-date the use of field-based weighting models, as proposed by Zaragoza et al. [TREC 2004]. For such field-based weighting models, the 'number of times that the term occurs in field f in this document' is the important, not just the presence.

      Terrier should support such counting fields, in terms of indexing support and Matching/weighting model support.

        Attachments

          Issue Links

            Activity

            craigm Craig Macdonald added a comment -

            Lexicons will have to contain field information. It is important that the Lexicon rewrite facilitate this.

            craigm Craig Macdonald added a comment -

            This is also waiting for TR-20. Indeed, TR-20 contains the FieldPosting interface that this patch will implement.

            jeffye Jeffye added a comment -

            I think It's very hard to patch this. Could you write a step-by-step tutorial? Or release a new 2.x version? Thanks!

            Even after I fixed some minor problems in the patch files, I still can not get through.
            My patch sequence: TR-20.v1.patch , TR-14.v3.svn.patch , TR-13.v0.patch . Is there any other strict I should follow?

            craigm Craig Macdonald added a comment -

            Duplicate of TR-43, TR-48, TR-69, TR-70


              People

              • Assignee:
                craigm Craig Macdonald
                Reporter:
                craigm Craig Macdonald
              • Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: